bigace:upgrade:25

Upgrading BIGACE from Version 2.4 to 2.5

The Upgrade to 2.5 is supported from the latest available stable release 2.4 and 2.5 x.

Please read about the changed requirements with 2.5.


You can watch a screencast to see how the upgrade process works in real life.

I recorded that video for all those who feel better also watching these infos, instead of only reading them.

Click to watch the tutorial screencast.


IMPORTANT

If you use the Comments extension, you need to install the latest version first (at least 1.1).

1. Create backup

Backup your filesystem and database before proceeding with the upgrade

Download upgrade package

Execute install.php and upgrade.php

  • Open install.php in your browser
  • Open upgrade.php and follow the steps (wait for every tasks to complete)

Edit /system/config/config.system.php

This is the new default config file. Please copy it into yours and apply the values. Remove all keys from your config, not shown here!

<?php

// ------------------------------ [CORE SETTINGS] ----------------------------
define ('BIGACE_TIMEZONE', 'Europe/Berlin');  // Timezone of your server, see http://de3.php.net/timezones
define ('BIGACE_URL_REWRITE', '');            // true/false = De-/activates rewriten/friendly URLs
define ('BIGACE_DIR_PATH', '');               // BIGACE root directory, relative from DocumentRoot

// ------------------------------ [DATABASE CONNECTION] ----------------------------
$_BIGACE['db']['type']                = 'mysql';
$_BIGACE['db']['character-set']       = 'utf8'; 
$_BIGACE['db']['host']                = 'localhost'; // database server name, ip or localhost
$_BIGACE['db']['name']                = ''; // the db name 
$_BIGACE['db']['user']                = 'root'; // db user name
$_BIGACE['db']['pass']                = ''; // password for the above user
$_BIGACE['db']['prefix']              = 'cms_'; // prefix for the table names (can be empty!)

Make sure there is no closing ?> and the file starts with <?php - there is no whitepace allowed at the beginning.

Migrate to UTF-8

  1. Read the article BIGACE UTF8 conversion
  2. Read the instructions at the conversion helper page
  3. Execute the conversion by using the utf8.php script (included in your upgrade package)

6. Configurations

You have to set these values manually in Administration at System/Configurations for EVERY community!

  • community / contact.email
  • community / default.language
  • community / sitename
  • editor / default.editor

7. Check Smarty Templates

If you used the {content} TAG before, you have to change your template code.

The {content} TAG is now used to fetch “additional contents” from the page. It is NOT used for fetching the pages main content any longer.

In most cases it should work, if you replace {content} by {modul}.

Please have a look the Wiki pages:

8. The last step: Remove files from additional language packs

If you installed additional language packs like Swedish, Finnish or Turkish there might be some files left, which cause troubles in administration (forum thread).

You need to make sure that the following folders are gone:

  • /system/admin/plugins/menu/menuAdmin/
  • /system/admin/plugins/menu/menuTree/

Probably there are more folders left, which can cause problems. If you cannot open an admin screen after upgrading “not found”, please post the URL in our forum, we will fix the problem together!

9. Browser Cache

If you experience problems, using administration and/or editor, please clear your browser cache, to make sure the new stylesheets are used.

10. Congratulations

You did it! Yes, this update was a tough one, I know.

Sorry folks, but the UTF-8 conversion was a required step for future development.

bigace/upgrade/25.txt · Last modified: 2016/01/16 16:45 by kevin